[Wlug] ssh2 -> openssh

Bill Mills-Curran subssn594@charter.net
Mon, 4 Jun 2001 23:45:46 -0400 (EDT)


Tonight I tried (briefly) to convert to openssh from ssh2, and I ran into
trouble.  Maybe someone has an idea.  The two machines in question are at
RedHat 6.1 and RedHat 7.0.  

I built ssh2 (version 2.4.0) on each machine, and the install went
smoothly on both sides.  I have been happy with it.  Then a friend
suggested openssh.  So I thought I'd try to convert.

Since I could not find a ready-build openssl and openssh rpm for 6.1, I
build openssh 2.9p1 and openssl 0l.6.6a.  On my 7.0 box, I used the rpm's
from the distro.

I deinstalled the ssh2 code using "make install".  I did not try to remove
any other files, but I did stop all ssh2 processes.  The install of the
openssh code went just fine.

I could log into my 7.0 box from my 6.1 box (I can't go the other way due
to a company firewall), but the port mapping did not work.  (I used the
"-R 19999:box1:23" to give me access back through the company firewall.)

I'm wondering if I'm running into basic code problems, or is it likely
that the ssh2 installation needs some careful manual cleanup prior to
decommission it.

I'm back running ssh2, but I'd like to stick with open source, if
possible.  Suggestions?

Thanks,
Bill